×

Fill the form and have
a Morgan contact you!

*red highlight indicates mandatory fields

What are the minimum system requirements to run my SchweserPro™ QBank?

Posted on March 11, 2015 9:31 am;

Share this article:

To run your SchweserPro™ QBank, you’ll need the following:

Compatible browsers

- Internet Explorer 8, 9, 10 (8 does NOT support animation)
- Chrome 30+
- Mozilla Firefox 15+
- Safari 5.1.1+

Software (latest download is recommended)

- Adobe Acrobat Reader
- Flash Player
- Java

Compatible operating systems

- Windows (7, 8, 8.1)
- MAC 10.6 or higher
- Display size to use
- 1024 x 768 or larger

Please note that only the online version of the SchweserPro™ Qbank works on a Mac computer (compatible with Firefox). The SchweserPro™ QBank Download do not work on Mac computers.

Share this article: